GUI issue - reposted from Facebook posting.

classic Classic list List threaded Threaded
25 messages Options
12
Reply | Threaded
Open this post in threaded view
|

GUI issue - reposted from Facebook posting.

Mark Harvey
Administrator
Hi
I would need help!
I dunno where to look about this one, couldn't find anything on the forum. Everything works like a charm, NB7 is fine, but the web page gui, when I login...
After I logged on with the mhvtl password, the text box goes away and the page stays there. I have to add manually html/mhvtl.php I can't find why.

I am sure that its not the software but some configuration somewhere on my side. can you point me where I need to look to get more help !?

Much appreciated and nice piece of program you built Nia !
Regards from Australia
Mark Harvey
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
Sounds like web browser not redirecting properly for some reason. Could be compatibility issue that needs to be figured out..

I wonder which GUI version being used and which browser .. Or maybe PHP on the web server .. Who knows ..


Regards,

-nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
In reply to this post by Mark Harvey
i will let you know which version i run once i am home... i am the one who sent message via facebook.
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
oh, where did it got my image from? google ? hah aha my old image somehow got here...
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
In reply to this post by nia
Hi, there is the info about version I am using;

I have the GUI version 1.4.9-62caed7
console 1.5.0-5290ce3

tried with explorer 10, using different mode (pressing f12)
tried with firefox 24

my php is
$ php -version
PHP 5.3.3 (cli) (built: Jul 12 2013 14:17:26)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

$ httpd -version
Server version: Apache/2.2.15 (Unix)
Server built:   Aug 13 2013 10:51:17

$ uname -a
Linux linux.crishna.local 2.6.39-400.209.1.el6uek.x86_64 #1 SMP Tue Sep 10 20:39:39 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux

and when I logged on, it stays like that
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
Thanks for the additional info. I will look into a fix very soon.

Regards,

-nia
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
In reply to this post by crishna
Could you run the following via command line and post the output :

php login.php

Thanks

-nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
can't post the output! I get the message

  [Spam Detector] Message contains common spam words.  

from the forum....
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
Hmmm .. Could you use the "Raw Text" input option under More ?
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
root@linux /var/www/mhvtl
$ php ./login.php
<html>
<head><title>MHVTL Web Console</title></head>
<LINK REL="SHORTCUT ICON" HREF="favicon.ico">
<link href="html/styles.css" rel="stylesheet" type="text/css">
<body>
<center>
<hr width="100%" size=10 color="blue">

<tr>
<td>
<img src="html/images/mhvtl.png" ALIGN="center" hieght=128 width=192 ><br><b><FONT COLOR=#000000 size=5>Linux Virtual Tape Library System</FONT></b>
</td>
</tr>

<br>
<a href="http://sites.google.com/site/linuxvtl2/"><b><font size=1>Developed by Mark Harvey & Community (markh794@gmail.com)<b></a>
<br>
Web Console GUI built by (nia) <a href="http://mhvtl-community-forums.966029.n3.nabble.com/">mhvtl-community-forums</a>
<hr width="100%" size=1 color="blue">
<br><br>
<TABLE BORDER=1 CELLSPACING=4 CELLPADDING=4 bgcolor=#000000 <FONT COLOR="#FFFFFF"></FONT>
<TR>
<TD>
<div style="overflow:auto;height:250px;width:400px;" >



<br><br><b><FONT COLOR=#FFFFFF><center> linux.crishna.local
 </center></FONT></b><pre><center><b><FONT COLOR=#FFFF00>MHVTL Release 1.4.9-62caed7
</FONT></b></center></pre><pre><FONT COLOR=#FFFFFF></FONT></pre><pre><FONT COLOR=#FFFFFF></FONT></pre><pre><FONT COLOR=#FFFFFF></FONT></pre><pre><FONT COLOR=#FFFFFF></FONT></pre><html>
<head><title>MHVTL Web Console</title></head>
<LINK REL="SHORTCUT ICON" HREF="favicon.ico">
<link href="html/styles.css" rel="stylesheet" type="text/css">
<body>
<center>

PHP Warning:  session_start(): Cannot send session cookie - headers already sent by (output started at /var/www/mhvtl/login.php:28) in /var/www/mhvtl/go.php on line 8
PHP Warning:  session_start(): Cannot send session cache limiter - headers already sent (output started at /var/www/mhvtl/login.php:28) in /var/www/mhvtl/go.php on line 8
<FONT COLOR=green><b>Enter Password </b></FONT>
<br>
<form method="post" action="">
<input type="password" name="pswd">
<br><input type="submit" name="login" value="Login">
</form>

</br>
</center>

</body>
</html>
<pre><center><FONT COLOR=#2B60DE ><b>Console Version 1.5.0-5290ce3
</b></FONT></center></pre>
</div>
</TR>
</TD>
</table>

<br><br>
<pre><b><FONT size=2><a href='http://www.gnu.org/licenses/gpl-2.0.html'>GNU GENERAL PUBLIC LICENSE : GPLv2 : Copyright (C) 2011. All rights reserved.</a></FONT></b></pre></center>
</body>
</html>

nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
I just pushed some updates in github .. could you download and let me know if it works.
The GUI Live update feature may not until you get the new version manually since it includes related fixes.

Just use the following again :

 git pull http://github.com/niadev67/mhvtl-gui.git

Regards,

-nia
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
nia wrote
Just use the following again :

 git pull http://github.com/niadev67/mhvtl-gui.git

Regards,

-nia
I meant using https :

git pull https://github.com/niadev67/mhvtl-gui.git
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
ok, I will test that! posting soon...
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
root@linux /root/git-repository/temp
$ git clone https://github.com/niadev67/mhvtl-gui.git
Initialized empty Git repository in /root/git-repository/temp/mhvtl-gui/.git/
error:  while accessing https://github.com/niadev67/mhvtl-gui.git/info/refs

fatal: HTTP request failed

I get a error 403 when browsing via web. forbidden..
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
is the change you made are the following for my little problem ?! if so I will modify go.php ....

-<?php session_start();  
    8    +<?php  
    9    +  
    10    +ob_start();   
    11    +ob_flush();  
    12    +@session_start();  
    13    +  

Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
with these change, I am having the same results as before...
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
I am not sure now .. it sounds like the browser is blocking the PHP include for login.php or not running it. It arrears to be fine when you run command line. Can you look at some logs under /var/log/httpd to see if it shows anything  ?

Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
yes! there is a log in error.log...

$ cat error_log |grep mhvtl
[Sun Oct 13 06:52:27 2013] [error] [client 192.168.10.25] PHP Warning:  Cannot modify header information - headers already sent by (output started at /var/www/mhvtl/login.php:28) in /var/www/mhvtl/go.php on line 18, referer: http://linux.crishna.local/mhvtl/login.php
[Sun Oct 13 06:52:49 2013] [error] [client 192.168.10.25] PHP Warning:  Cannot modify header information - headers already sent by (output started at /var/www/mhvtl/login.php:28) in /var/www/mhvtl/go.php on line 18, referer: http://192.168.10.20/mhvtl/login.php
nia
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

nia
Administrator
Check for blank lines in login.php !!! .. Or download a fresh copy form GitHub :  https://github.com/niadev67/mhvtl-gui/blob/master/login.php
Reply | Threaded
Open this post in threaded view
|

Re: GUI issue - reposted from Facebook posting.

crishna
Hi,

I took the login.php from the link you provided. I did a display RAW option, then I cut and pasted into the file under my Linux server. "moved the old one to .old before" re-tried web page, same results.

diff of the 2 files are as shown here...

$ diff login.php login.php.old
99,100d98
<
<

I still have the same results, I can put the password of mhvtl, then the password box goes away and the square stay black. no menu, nothing... is there anything else I can provide, to help in the case... like maybe the apache config ? perl or php config !? even access to the workstation! ;-)

I will provide whichever information you need/request.

best regards.

Francois Desfosses.
12