auto creat targets error

classic Classic list List threaded Threaded
4 messages Options
zy
Reply | Threaded
Open this post in threaded view
|

auto creat targets error

zy


After update new version 1.4.10,i get this error.
The file /etc/tgt/targets.conf.mhvtl is empty.Configrations can`t be saved.
what should i do?
nia
Reply | Threaded
Open this post in threaded view
|

Re: auto creat targets error

nia
Administrator
The "tgt-admin --dump" is Linux SCSI target framework ( tgt ) utility and not mhvtl .. What version of tgt are you running ?

I am currently at 1.0.40-cc6501c and don't have any issues ..

I will update mine soon also to see if this issue started in one of tgt recent releases.

-nia
zy
Reply | Threaded
Open this post in threaded view
|

Re: auto creat targets error

zy
i updated tgt to 1.0.42 use live update in the MHVTL GUI yesterday,then i got the error.
today, i recheck the update it has new version 1.0.43,after update i got same error.like this:

Try `tgtadm --help' for more information.
-C argument value '0' out of range

when i restart tgtd daemon,i got same error.
it`s tgt update issue.

after i reinstall tgt, it works ok.
thanks for nia

[root@localhost lib]# service tgtd stop
Stopping SCSI target daemon:                               [  OK  ]
[root@localhost lib]# service tgtd start
Starting SCSI target daemon:                               [  OK  ]
-C argument value '0' out of range
Try `tgtadm --help' for more information.
-C argument value '0' out of range
Try `tgtadm --help' for more information.
-C argument value '0' out of range
Try `tgtadm --help' for more information.
-C argument value '0' out of range
Try `tgtadm --help' for more information.

[root@localhost lib]# yum install scsi-target-utils
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirrors.yun-idc.com
 * extras: mirrors.yun-idc.com
 * updates: mirrors.163.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package scsi-target-utils.x86_64 0:1.0.24-3.el6_4 will be updated
---> Package scsi-target-utils.x86_64 0:1.0.24-10.el6 will be an update

--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================
 Package                                      Arch                              Version                                  Repository                       Size
===============================================================================================================================================================
Updating:
 scsi-target-utils                            x86_64                            1.0.24-10.el6                            base                            175 k

Transaction Summary
===============================================================================================================================================================
Upgrade       1 Package(s)

Total download size: 175 k
Is this ok [y/N]: y
Downloading Packages:
scsi-target-utils-1.0.24-10.el6.x86_64.rpm                                                                                              | 175 kB     00:00    
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : scsi-target-utils-1.0.24-10.el6.x86_64                                                                                                      1/2
  Cleanup    : scsi-target-utils-1.0.24-3.el6_4.x86_64                                                                                                     2/2
  Verifying  : scsi-target-utils-1.0.24-10.el6.x86_64                                                                                                      1/2
  Verifying  : scsi-target-utils-1.0.24-3.el6_4.x86_64                                                                                                     2/2

Updated:
  scsi-target-utils.x86_64 0:1.0.24-10.el6                                                                                                                    

Complete!
[root@localhost lib]# ls
anaconda-runtime  bonobo  ConsoleKit  cups  games  gcc  locale  mozilla  python2.6  rpm  sendmail  sendmail.postfix  tgt  vmware-tools  yum-plugins
[root@localhost lib]# cd tgt
[root@localhost tgt]# ls
[root@localhost tgt]# cd ..
[root@localhost lib]# service tgtd stop
Stopping SCSI target daemon:                               [  OK  ]
[root@localhost lib]# service tgtd start
Starting SCSI target daemon:                               [  OK  ]
nia
Reply | Threaded
Open this post in threaded view
|

Re: auto creat targets error

nia
Administrator
You can update your tgt now and should work as did before .. New patch was just applied to fix the issue.

https://github.com/fujita/tgt/commit/e2cdfe52e221f11a67329efdee13c66429e94c18


-nia