netbackup restore error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

netbackup restore error

mingg663366
HI,i begin know mhvtl 0.18,all the default set.

my backup was successfully completed!

but when restore,the error occur:

--3:54 - begin Restore
--3:56 - 1 images required
--3:56 - media 1001L4 required
--3:57 - restoring image mainnbu_1396269726
--3:58 - Info bpbrm(pid=5332) mainNBU is the host to restore to      
--3:58 - Info bpbrm(pid=5332) telling media manager to start restore on client    
--3:58 - Info bpbrm(pid=5384) mainNBU is the host to restore to      
--3:58 - connecting
--3:58 - Info bpbrm(pid=5384) start tar32 on client        
--3:59 - Info bptm(pid=5368) Waiting for mount of media id 1001L4 (copy 1) on server mainnbu.
--3:59 - started process bptm (5368)
--3:59 - mounting 1001L4
--3:59 - requesting resource 1001L4
--3:59 - granted resource 1001L4
--3:59 - granted resource IBM.ULT3580-TD4.002
--4:00 - Info bptm(pid=5368) INF - Waiting for mount of media id 1001L4 on server mainnbu for reading.
--4:07 - Error bptm(pid=5368) block read is not a NetBackup or Backup Exec media header, len = 1024, media id 1001L4, drive index 2, data is unknown
--4:08 - Info tar32(pid=5420) Restore started.          
--4:08 - connected; connect time: 00:00:10
--4:10 - Info tar32(pid=5420) done. status: 0          
--4:10 - Info tar32(pid=5420) done. status: 0 - the requested operation was successfully completed  
--4:10 - Info bpbrm(pid=5332) child done, status 0        
--4:12 - Info bpbrm(pid=5332) got ERROR 172 from media manager       2
--4:12 - restored image mainnbu_1396269726 - (cannot read media header, may not be NetBackup media or is corrupted(172)); restore time 00:00:15
--4:12 - Warning bprd(pid=5192) Restore must be resumed prior to first image expiration on
--4:13 - end Restore; elapsed time: 00:00:19
Restore error(2850)

who can help me?
Reply | Threaded
Open this post in threaded view
|

Re: netbackup restore error

Mark Harvey
Administrator
0.18 - Wow, that was released back in December 2009..

Can you confirm the version of the mhvtl kernel module.. (cat /sys/module/mhvtl/version and/or modinfo mhvtl)

The original 0.18 release contained a bug in the kernel module which would silently corrupt data to/from virtual media.
0.18-1 contained the updated kernel module (15th December 2009)
- kernel module with a version string of 0.16.9 is suspect and needs to be upgraded..
- kernel module with a version string of 0.18.2 or later is OK.
The last 0.18-17 was released mid 2011.

I would strongly recommend upgrading to the latest 1.4-10 and re-testing.. Unfortunately, media density reporting has changed between 0.18 and 1.4 release. You will need to remove all media under the /opt/mhvtl/ before installing the upgraded 1.4-10 binaries.

Included with the 1.4 release is a utility "dump_tape" - once you have upgraded, can you please supply the output of "dump_tape -f E01001L4" (or if new tests pick another media ID - use the associated barcode with the media id)

You should notice the first block is 1k in size (for a correctly formatted media by NetBackup) - anything else is 'bad'..

Regards from Australia
Mark Harvey